Komunikimi Host me Host

Pas diskutimit me përbërjen e modelit OSI dhe disa nga pjesët kyçse të përfshira në lëvizjen e pakove nga një host në një tjetër, ne fund mund të diskutojmë funksionet specifike që ndodhin në lejimin e Host me Host komunikimit.

Në thelbin e internetit është ideja se dy kompjuterat mund të komunikojnë me njëri-tjetrin. Edhe pse është e rrallë për të gjetur situatat kur dy hostet janë të lidhura direkt me njëri-tjetrin, të kuptuarit se çfarë ndodh në qoftë se ata ishin të  rëndësishëm për të kuptuar çdo gjë tjetër që ndodh kur pret hoste të shumta që komunikojnë përmes një switch apo router.

Si i tillë, ky artikull do të përqëndrohet në host to host komunikimit, dhe çdo hap individual të përfshirë në këtë proces.

 

Komunikimi Host me Host

Që nuk ka Router në këtë ilustrim, ne e dimë se i gjithë komunikimi po ndodh në të njëjtin rrjet – pra, Host A dhe Hosti B janë të dyja të konfiguruar me IP adresat që i përkasin të njëjtit rrjet.

10.png

Çdo host ka një IP adresë dhe MAC adresë. Që çdo host ka gjithashtu një pajisje L3(shtresa 3), ata kanë gjithashtu edhe Tabela ARP. Në këtë moment, tabelat e tyre ARP janë bosh.

Host A fillon duke krijuar disa të dhëna për Hostin B. Hosti A e di destinacionin përfundimtar për këto të dhëna do të jetë IP adresa 10.10.10.20 (Host B). Host A e di adresën e vet (10.10.10.10), dhe si i tillë është në gjendje të krijojë një heder L3 me burim dhe destinacion i kërkuar nga IP Addresa.

Por siç kemi mësuar më parë, dërgimi i pakove është puna e L2, kështu që pavarësisht se këto hoste janë duke u lidhur direkt me njëri-tjetrin, një header L2 duhet të jetë krijuar.

Burimi i headerit L2 do të jetë MAC adresa (aaaa.aaaa.aaaa). Destinacioni i hederë L2 duhet të jetë MAC adresa e hostit B, por në këtë moment, Host A nuk ka një hyrje në tabelën e saj ARP për IP adresën e B-së, dhe për këtë arsye, nuk e di MAC adresën e B.

Si rezultat, Host A nuk është në gjendje për të krijuar headerin L2 për ti ofruar pako hostit B në këtë kohë. Host A do të duhet të iniciojë një kërkesë ARP në mënyrë që të marrin informacionin që mungon:

11.png

ARP Kërkesa është një pako e vetme e cila në thelb pyet: “Në qoftë se ka dikush atje me IP 10.10.10.20, ju lutem më dërgoni adresën tuaj MAC.

Hosti B mund të përdorë këtë informacion të ri për t’iu përgjigjur direkt hostit A. Reagimi i ARP është dërguar si mesazh unicast, drejtuar direkt hostit A. Sikur të kishin qenë hoste të tjera në këtë lidhje, atëher nuk do të kishte parë përgjigjje ARP-ja.

Reagimi i ARP do të përfshijë të dhënat e Hostit A : Dhe IP Adresa 10.10.10.20 është duke u shërbyer nga NIC me MAC adresën bbbb.bbbb.bbbb. Host A do të përdorë këtë informacion për të populluar Tabelat e ARP:

12.png

Me Host A ARP Tabela është populluar, Host A tani me sukses mund të vë së bashku headerin e duhur L2 për të marrë pako të hostit B.

Kur Host B merr të dhënat, do të jetë në gjendje t’i përgjigjet pa zhurmë më tej, pasi ajo tashmë ka një hartë në tabelën e saj ARP për Hostin A.

 

Advertisements

Rrugëtimi i pakove

Në këtë seri, ne kemi studiuar shtresat e ndryshme të modelit OSI, dhe se si secili nga shtatë shtresa ofron një shërbim unik të cilin shtresat e tjera varet.

Ne gjithashtu do të studiojmë pjesët kryesore të internetit, ku janë të përcaktuara një Host, Client, Server, Switch, Router, dhe ARP. Si dhe secili prej roleve të tyre unike në lëvizje një pako në rrugën e saj.

Ne pastaj shikojmë punimet specifike të një Switch, dhe funksionet e tij të sakta si ajo lehtëson komunikimin në një rrjet. Pastaj ne shikuar në punimet e veçanta të një Router, dhe pikërisht se si ajo lehtëson komunikimin në mes rrjeteve.

Së fundi, koha e tij për të përfunduar paketën e Udhëtim në seri shihet me një video që lidhjet janë të gjitha së bashku. Në vijim, ne do të shikojmë çdo gjë që ndodh për të marrë të dhëna nga stacioni A në stacionin D, si ai kalon nga një Host, përmes një Switch, në një Router, përmes një Switch, dhe më në fund në destinacionin e vet përfundimtar.

EIGRP Metric

EIGRP Metricë ka shkaktuar konfuzion për shumë inxhinierë të rrjetit duke u përpjekur për të kuptuar protokolin. Ky artikull do të zhytet në atë që është matricë, dhe do të valoj poshtë në formën e saj të thjeshtuar.

Formula dhe K-Vlerat

EIGRP është një protokol rrugetimi dhe është krijuar në vitin 1980. Si e tillë, Cisco ishte shitësi i vetëm që ka të drejtat për të zbatuar tha EIGRP protokoli. Deri në vitin 1998, kur Cisco ka lëshuar specifikimin si një draft IETF.

Një nga përfitimet kryesore të EIGRP është në gjendje të marrë parasysh atribute të ndryshme, kur bën llogaritjen e kostos në një rrugë, apo matricë. Gjegjësisht, EIGRP është një nga protokolet e rrugëtimit që mund të konsiderojë çdo kombim të Bandwidth, ngarkesës, vonesë, dhe besueshmërinë në llogaritjen e saj me kosto.

Secila nga këto atribute janë të kontrolluara nga ajo që është e njohur si një vlerë e K. Këto K-vlera munë ta bëjn të mundur shqyrtimin e një prej cilësive të lartpërmendura, si dhe shkallën në të cilën konsiderohet atributi.

K1 = Bandwidth
K2 = Ngarkesa
K3 = Vonesa
K4 & K5 = Besueshmëria

Secila prej këtyre vlerave janë përdorur në atë që e quajm EIGRP formula të përbëra nga maticat. Kjo formulë është si vijon:

EIGRP metric:

             256 * { K1*BW + [(K2*BW)/(256-load)] + (K3*delay) } * { K5/(reliability+K4) }

Ajo duket shumë e komplikuar, por ne mund të thjeshtojmë atë disi nga rishkrimi i sajë në një format tjetër dhe thyer çdo pjesë me ngjyra të bukura:

 

eigrp-metric9.png

 

Te K-Vlerat është vetë një numër mes 0 dhe 255. Ju mund të vendosni çdo vlerë të bazuar në mënyrë të pavarur nga ajo që ju doni parasysh në llogaritjen e kostos për çdo rrugë. Nëse në domenin tuaj ju dëshironi të konsiderojnë një nga atributet e mësipërme, ju mund të vendosni K-vlerën e duhur në zero. Nëse dëshironi të marrin në konsideratë një atribut, ju mund të vendosni vlerën e duhur K-vlerë.

Duhet të theksohet, megjithatë, se nëse dy routers do të bëhen fqinjët e EIGRP, ata duhet të kenë përputhjen e K-vlerave. E cila ka kuptim, për shkak se në qoftë se një router konsideron shtyrjen si të rëndësishëm të madhe, dhe tjetri e konsideron Bandwidth si të rëndësishëm të madhe, atëherë ata mund të pajtohen se cila rrugë në një rrjet destinacion është e mirë.

 

EIGRP Kushti i Fizibilitetit

EIGRP është një protokol ruter strategjia e të cilit për të parandaluar ruter sythe bazohet në atë që njihet si Kushti Fizibilitetit EIGRP. EIGRP gjithashtu e bën përdorimin e një koncepti të quajtur Split Horizon, e cila do të prek shkurtimisht më vonë në këtë artikull.

Për të duhet të diskutojë Kushti fizibilitetit megjithatë, duhet të keni një kuptim të termave të mëposhtme EIGRP: pasardhësi, pasardhësi i mundshëm, Raportuar në Distance, dhe Distanca realizueshme. Ju gjithashtu do të duhet të kuptoni që si është llogaritur një EIGRP matricë. Për fat të mirë, secili prej këtyre koncepteve janë mbuluar në artikuj të tjerë.Ne do të jemi duke e përdorur këtë topologji për të përshkruar gjendjen e Fizibilitetit dhe si funksionon:

 

eigrp-fc-r4-IP6.png

 

Në këtë topologji, ne kemi katër routers EIGRP. Pavarësisht se duke qenë shumë rrjete IP, ai do të përqëndrohet në është 9.9.9.0/29 rrjeti lidhur me R4.

Çdo lidhje në topologji gjithashtu tregon koston Lidhje EIGRP. Ne do të përdorim këto për të llogaritur distancën e mundur çdo router dhe raportohojmë Distancen. Për shembull:

Distanca e mundshme R4 për 9.9.9.0/29 është 256
Distanca e raportuar R4 është 0, pasi rrjeti është e lidhur direkt
Distanca e mundshme R3 për 9.9.9.0/29 është 2816 (2560 + 256)
Distanca e raportuar R4 është 256 nga rruga shpallur nga R4
Nëse ndonjë nga këto pika nuk ka kuptim, të shqyrtojmë artikullin EIGRP Terminologjia  ilustron se si distanca raportuar dhe distanca e mundur të punojnë.

Nga kjo rrugë, duhët diskutuar nga EIGRP konceptet më konfuze, kusht Fizibilitetit.

 

Feasibility Condition

 

Kushti i Fizibilitetit thuhet se një rrugë nuk do të pranohet nëse distanca Raportuar është më shumë se Largësia mundshme rrugën më të mirë .

Apo thënë në një mënyrë tjetër dhe nga perspektiva e router: një rrugë në një rrjet nuk do të pranohet, nëse kostoja e fqinjit tim është më shumë se kostoja e ime.

Për të ilustruar këtë, ne do të shikojmë vlerat për Largësin e realizueshme (FD) dhe për të raportuar Largimin (RD) për R1, R2, R3 dhe si reklama për rrjetin 9.9.9.0/29 të përhapur në të gjithë topologji.

 

Mohimi i një rruge me një loop

 

Ne do të fillojmë nga reklama e rrugës për rrjet që R4 gjeneron të R3  9.9.9.0/24, dhe R3 nga ana tjetër reklamon për R2, e cila  reklamon atë R1, pastaj në fund përsëri në R3. Njoftim R3 do të marrë dy reklama njërin prej R4, dhe një tjetër nga R1  bëjnë rrugën e tyre nëpërmjet R2.

eigrp-fc-r37.png

Ne thjesht mund të shohim se shpallja që shkoi nga R4 për R3 nuk krijon një loop, ndërsa ai që shkoi nga R4 për R3 për R2 për R1 pastaj përsëri në R3 ka krijuar një loop. EIGRP do të vijnë në të njëjtin përfundim, duke testuar shpallje nga R1 kundër Kushtit të Fizibilitetit.

Siç u tha më lart, Kushti i Fizibilitetit thotë se një rrugë nuk do të pranohet nëse Largësia raportuar është më shumë se Largësia mundshme .Rruga më e mirë për të   është R3 9.9.9.0/29 është nëpërmjet R4, pasi ajo ka Distancen e mundshme 2816.

Rruga nga R1 përmban një distancë e raportuar 5888. Kjo vlerë është më e lartë se Largësia më e mirë e mundshme R3 (2816), për këtë arsye, shpallje nga R1 shkel Kushtin e Fizibilitetit dhe do të injorohet nga R3.

Ky është një shembull se si EIGRP shmang rrugën e pranuar me një loop duke përdorur Kushtin e Fizibilitetit.

 

Duke pranuar rrugën Loop

 

Ne do të hedhim një vështrim në reklama të marra nga perspektiva e R2:

 

eigrp-fc-r28

 

Nëse ne të përhapur reklama e rrugës për rrjetin 9.9.9.0/29 në të gjithë rrjetin, atëher R2 do të marrë dy reklama: njërin prej R4 në R3 në R2, dhe tjetri nga R4 për R3 R1 për të R2. Rruga e preferuar do të jetë ai me R3, pasi ajo ka një të mirë (më të ulët) Distanca e mundshme 4864.

Rruga nga R1 përmban një distancë të raportuara 4096. Kjo vlerë është më e ulët se Largësia më e mirë e mundshme e R2-së nga R3 (4864), për këtë arsye, reklamimi nga R1 do të pranohet pasi që nuk shkel Kushtin e Fizibilitetit.

Kjo do të lejojë R2 për të mbajtur gjurmët të mira, shtigjet loop-free për të marrë të 9.9.9.0/29. Rruga me Largësi të ulët e mundshme do të ruhet si rrugë trashëgimtare, dhe do të populloj Routing Tabela e router-it. Rruga tjetër do të ruhet në Topologji tabelën e EIGRP si Pasardhës i mundur, dhe do të jetë gati për të zëvendësuar Pasardhësin, menjëherë duhet të ndodhë diçka për lidhjen midis R2 dhe R3.

 

 

Virtual Local Area Networks (VLANs)

Virtual Rrjetet Lokale Area, ose VLANs, janë një koncept shumë i thjeshtë që ka qenë shumë i dobët përcaktuar nga industria.

Ky artikull do të shpjegojë VLANs nga një perspektivë praktike. Ajo do të jetë i përshtatur rreth dy funksioneve kryesore të VLANs, dhe më pas përfundoi me një koncept po aq të definuar dobët, VLAN native.

Së fundi, në fund të artikullit është një kuptim sfidë dy pyetje – në qoftë se ju mund të përgjieni saktë këtyre dy pyetjeve, atëherë ju mund të konsideroni veten për të kuptuar plotësisht konceptin e VLANs – temën e VLANs konfiguruar do të mbulohet në një tjetër artikull.

Dy Funksionet kryesore të VLANs :

Më poshtë është një rrjet me tre switcha te ndryshëm fizike. Ndryshon të lehtësojë komunikimin brenda rrjetit, dhe Routers të lehtësojë komunikimin midis rrjeteve.

 

untitled5

Çdo switch mbi të në mënyrë të pavarur kryen katër funksionet e switchit.Nëse secili prej këtyre ndizet, kanë 24 porte dhe vetëm dy janë në përdorim, atëherë 22 portet janë lënë të humbur në çdo switch. Për më tepër, ajo që në qoftë se ju duhet të përsëris këtë rrjet diku tjetër dhe ju nuk keni tre switcha fizike për të akomoduar?

Kjo është ku funksioni i parë i madh i një VLAN vjen në lojë: A VLAN ju lejon të marrin një kaloni fizike, dhe të ndërpreni atë deri në të vogla mini-switches

Konfigurimi VLANs në Cisco Switches

Ne kemi shkruar më parë në lidhje me VLANs dhe çfarë ata mund të bëjnë si një koncept. Ky artikull do të përqëndrohet në konfigurimin VLANs në Cisco switches.

Ne do të shikojmë në çdo komandë e nevojshme për të konfiguruar topologji më poshtë. Nëse kjo topologji duket e njohur, kjo është për shkak se ju e keni parë atë në artikullin të cilin e përshkroi si VLANs vepruar në një nivel konceptual.

 

vlans-configuration-topology4

 

Ne së pari do të shikojmë se çfarë shkon në konfigurimin në portet e hyrjes në topologji më poshtë, e ndjekur nga ajo që shkon në konfigurimin portet trunk. Atëherë ne do të shikojmë në disa porte të verifikimit dhe të tregojmë komandat për të vërtetuar atë që është konfiguruar. Së fundi, ne do të shikojmë në konfigurimin e parazgjedhur për një port swich, kështu që ne e dimë pikën tonë të fillimit, kur ne jemi duke aplikuar komandat qe kemi diskutuar.

 

Portet Access

-Një port qasje është një port switch që është anëtar i vetëm i një VLAN. Ka dy pjesë për të konfiguruar një port qasje: krijimin e VLAN në VLAN të të Dhënave ne Switch dhe caktimin port switch në një VLAN.

 

Krijimi i VLAN në VLAN Database

Para se një switch do të pranojë  një VLAN, VLAN duhet të ekzistojë në VLAN Database Switch. Shtimi i një VLAN në bazën e të dhënave VLAN kërkon vetëm një komandë:

SwitchX(config)# vlan 10               


Nga kjo pikë, ju mund të bëni opsionale emrin VLAN. Kjo do të bëjë VLAN më të
lehtë për të identifikuar.Për të përmendur një VLAN, thjesht përdorim emrin
dhe urdhërojmë direkt :

SwitchX(config-vlan)# name RED
Për VLAN 20, ne do të krijojmë edhe emrin e VLAN në SwitchX:

SwitchX(config)# vlan 20
SwitchX(config-vlan)# name ORANGE


Vini re se një VLAN vetëm duhet të shtohet në bazën e të dhënave një herë.
Nëse një VLAN tashmë ekziston në bazën e të dhënave VLAN, nuk është e 
nevojshme të ri-krijoni atë - ju mund të kërceni direkt në hapin e ardhshëm.
Më vonë në këtë artikull ne do të shikojmë disa komandat e përdorura për të
përcaktuar nëse një VLAN tashmë është krijuar.

Caktimi i switchport në një VLAN

-Tani që VLAN është në bazën e të dhënave VLAN, ne mund të konfigurojmë një 
port switch të jetë një port qasje për një VLAN veçantë. Ka dy komanda brenda 
mënyrën e konfigurimit ndërfaqe për këtë hap:

SwitchX(config)# interface Ethernet 0/0
SwitchX(config-if)# switchport mode access
SwitchX(config-if)# switchport access vlan 10
Qasja në komanda që mënyra switchport vendos portin si një port të qasjes, dhe 
switchport qasje vlan <#> komandën përcakton portin si një anëtar i VLAN 10.
Disa versione të Cisco switches automatikisht janë të krijuar VLAN në VLAN 
Database kur caktoni një port qasje në një VLAN:

SwitchX(config)# interface Ethernet 0/1
SwitchX(config-if)# switchport mode access	
SwitchX(config-if)# switchport access vlan 30
% Access VLAN does not exist. Creating vlan 30
 

Router me interfaces të veçantë fizike

Mënyra më e thjeshtë për të mundësuar rrugë midis dy VLANs të thjesht të lidhë një port shtesë nga çdo VLAN është një Router.

 

rvlan-router-two-intf2

 

Router nuk e di se ajo ka dy lidhje në të njëjtën switch . Router-i  vepron  normal, kur gjen rrugë qe pakot te udhtojnë midis dy rrjeteve.

Në fakt, procesi i një pakete duhet lëvizur nga Host A do të presë D në këtë topologji do të punojë pikërisht ashtu siç bën në këtë foto. I vetmi ndryshim është që ka vetëm një kaloni fizike, nuk do të jetë vetëm një MAC Table Adres – secila hyrje përmban pasqyrimin e switchport në adresën MAC, si dhe numrin e VLAN ID që porti i takon.

Çdo port switch në këtë diagram është i konfiguruar si një port Access, ne mund të përdorim komandën varg për të konfiguruar portet të shumta si një herë:

 

 

Switch(config)# interface range eth2/0 - 2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 20

Switch(config)# interface range eth3/0 - 2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 30

Natyrisht, para se te bëhet caktimin i switchportit në një VLAN, kjo është një 
ide e mirë për të krijuar VLAN në VLAN Database.

Interfaces Router përdorë gjithashtu edhe një konfiguracion standard pë të 
konfiguruar një adresë IP dhe mundëson ndërfaqen:

Router(config)# interface eth0/2
Router(config-if)# ip address 10.0.20.1 255.255.255.0
Router(config-if)# no shutdown

Router(config)# interface eth0/3
Router(config-if)# ip address 10.0.30.1 255.255.255.0
Router(config-if)# no shutdown
Më poshtë ju do të gjeni komandat e ndryshme që tregojnë për Router dhe Switch 
,këto mund të përdoren për të kuptuar dhe vërtetuar se mjedisi është duke 
funksionuar.

Kurs Ndërmjet VLANs

Ne do te shkruajm një artikull i cili mbulon  Local Area Networks (VLANs) si një koncept dhe një tjetër artikull mbi konfigurimin VLANs në Cisco. Lënda e mbetur për të mbuluar është mundësitë e ndryshme që ekzistojnë për kurs mes VLANs.

Pse kemi nevojë për Routing Midis VLANs?

Siç kemi mësuar në një artikull të mëparshëm, VLANs të krijuar një ndarje logjike ndërmjet porteve Switch. Në thelb, çdo VLAN sillet si një switch i veçantë fizik. Për të ilustruar këtë, më poshtë janë dy fotografi topologjia e të njëjtin mjedis – një fizik dhe një logjike.

 

rvlan-physical

 

Pavarësisht nga të katër ushtritë duke u lidhur në të njëjtin kaloni fizike, topologji logjike e bën të qartë se pret në VLAN 20 janë në gjendje të flasin me pret në VLAN 30. Njoftim pasi nuk ka asgjë që lidh dy çelsin “virtuale”, ka asnjë mënyrë për të presë një të folur të presë C.

Që Hosti A dhe C  janë në VLANs të ndryshme, nënkuptohet gjithashtu se ata janë në rrjete të ndryshme. Çdo VLAN zakonisht do të korrespondojnë me rrjetin e saj IP. Në këtë diagram, VLAN 20 përmban rrjetin 10.0.20.0/24 network dhe VLAN 30 përmban rrjetin 10.0.20.0/24 network

Qëllimi i një Switch është për të lehtësuar komunikimin brenda rrjetit. Kjo puna e madhe për të qe te presë  duke u përpjekur për të folur për të pritur hostin B. Megjithatë, nëse Host A është duke u përpjekur për të folur për të pritur hostin C, ne do të duhet të përdorni një tjetër pajisje – një qëllimi i të cilit është për të lehtësuar komunikimin mes rrjeteve.

Nëse e keni lexuar Paketën Udhëtim seri, atëherë ju e dini se pajisja e cila lehtëson komunikimin në mes të rrjeteve është një Router.

Një router do të kryejë funksionin kurs të nevojshme për dy ushtrive në rrjete të ndryshme për të folur me njëri-tjetrin. Në të njëjtën mënyrë, një Router është ajo që ne do të duhet në mënyrë që pret në VLANs të ndryshme për të komunikuar me njëri-tjetrin.

 

Ekzistojnë tri opsione në dispozicion, në mënyrë që të mundësohet kurs mes VLANs:

Router me një Interface veçantë fizike në çdo VLAN
Router me një nën-Interface në çdo VLAN
Shfrytëzuar një Layer 3 Switch

Pjesa tjetër e këtij neni do të shqyrtojë këto tre opsione dhe konfigurimin e tyre.